Pixieset service issues
Incident Report for
Pixieset
Resolved
This incident has been resolved.
Posted
Dec
05
,
2025
-
01:19
PST
Monitoring
We are currently working with our third-party providers to resolve the issue. We appreciate your patience and understanding.
Posted
Dec
05
,
2025
-
01:12
PST
Update
We are continuing to investigate this issue.
Posted
Dec
05
,
2025
-
01:04
PST
Investigating
The Pixieset site is currently down. We are currently investigating this issue and will update as soon as we have more information.
Posted
Dec
05
,
2025
-
01:04
PST
This incident affected: Client Gallery, Mobile Gallery App, Website, Studio Manager and Services (Email Delivery, Photo Processing).
×
Subscribe to Incident
Subscribe to updates for
Pixieset service issues
via . You'll receive .