Users are unable to access Client Gallery
Incident Report for Pixieset
Resolved
Users are unable to access Pixieset. We are investigating and will provide an update shortly.

Update 19:23 PDT: This incident has been resolved.
Posted May 19, 2020 - 19:17 PDT