Technical Issues with Client Gallery Sharing

Incident Report for Pixieset

Resolved

This issue has been resolved. We apologize for any inconvenience.
Posted Jul 08, 2025 - 16:17 PDT

Monitoring

A fix has been implemented, and we are monitoring the results.
Posted Jul 08, 2025 - 16:14 PDT

Investigating

We are investigating technical issues with Client Gallery Sharing and Email History. Our engineering team is investigating and thank you for your patience in the meantime.
Posted Jul 08, 2025 - 16:04 PDT
This incident affected: Client Gallery.