This incident has been resolved. We apologize for any inconvenience.
Posted Apr 20, 2026 - 16:00 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 20, 2026 - 14:34 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted Apr 20, 2026 - 12:42 PDT
Investigating
We’re seeing delivery issues for emails sent to Yahoo, AOL, and Verizon addresses. We’re working with our email partners on a resolution and will provide updates. In the meantime, you can copy and share links directly with clients.
Posted Apr 20, 2026 - 09:06 PDT
This incident affected: Services (Email Delivery).